We are currently experiencing slow processing and UI performance issues. The system remains operational, but some users may notice delays in response times.
Posted Feb 12, 2025 - 11:59 UTC
Investigating
We are currently investigating this issue.
Posted Feb 12, 2025 - 11:31 UTC
This incident affected: Uptime of public API: api.cast.ai, Uptime of https://console.cast.ai, and Autoscaler.